ETMods.net

N!tmod, a Wolfenstein: Enemy Territory Modification!

You are not logged in.

Announcement

You can donate to help us keeping services online.

#1 22-Mar-13 22:27:47

Joe123
Member
Registered: 22-Mar-13
Posts: 1

I need this download link

Offline

#2 25-Mar-13 23:03:34

Dragonji
Member
From: Poland
Registered: 19-Aug-10
Posts: 88
Website

Re: I need this download link

Yeah, I'm waiting for 2.2.1 too to start another server. I don't want to use bugged 2.2 smile

Offline

#3 27-Mar-13 04:54:46

obituary
Member
Registered: 10-Mar-13
Posts: 5

Re: I need this download link

Yes is this 2.2.1 available anywhere? If someone has a copy can they upload it to speedyshare or a similar site so we can fix this memory leak?

Thanks in advance!

(Our server provider is sending me angry messages about my n!tmod server overloading the RAM on the server.)

Offline

#4 27-Mar-13 10:04:26

N!trox*
Administrator
Registered: 30-Mar-10
Posts: 1,092

Re: I need this download link

It's private, if we detect a server not allowed to use it will be remotely shutdown.
You have to apply to become a beta tester if you want to be allowed to use it and get access to the private beta forums.


iluvnitmod.png

Offline

#5 28-Mar-13 13:12:38

suzumya
Member
Registered: 21-Mar-13
Posts: 7

Re: I need this download link

N!trox* wrote:

It's private, if we detect a server not allowed to use it will be remotely shutdown.
You have to apply to become a beta tester if you want to be allowed to use it and get access to the private beta forums.

sounds like u dont give a fuk about it that all 2.2 server lagg. anyway its ur fault and u have to handle it. i rly love nitmod, but i think i will take silent mod since there is no chance to play with 2.2. just sad.

Offline

#6 28-Mar-13 16:37:14

N!trox*
Administrator
Registered: 30-Mar-10
Posts: 1,092

Re: I need this download link

I'm fed up with people complaining about not having access to 2.2.1... There is no documentation for NxAC, that's why I didn't want release it to public.
I don't have enough time to write the doc or work on the mod now so here's the download link for the latest build: http://etmods.net/forums/filedl.php?id=3
This download used to be allowed only for members of the beta testers group but since i have no free time, everybody can have it now.
Next time, talk better!


iluvnitmod.png

Offline

#7 28-Mar-13 17:52:25

N!trox*
Administrator
Registered: 30-Mar-10
Posts: 1,092

Re: I need this download link

Just to make it clear, it's a blacklist system that remotely shuts servers down, any server can run it but i can decide to restrict it by manually adding the IP to the blacklist. (I received emails from people who thought they could not use it without giving me the IP)


iluvnitmod.png

Offline

#8 28-Mar-13 18:46:57

Dragonji
Member
From: Poland
Registered: 19-Aug-10
Posts: 88
Website

Re: I need this download link

Regarding the AC: http://www.etlegacy.com/projects/etlega … span>-NxAC

Last edited by Dragonji (28-Mar-13 22:55:25)

Offline

#9 28-Mar-13 19:00:52

N!trox*
Administrator
Registered: 30-Mar-10
Posts: 1,092

Re: I need this download link

That's caused by a bad cvar scanner config, i recommend using this one: http://etmods.net/NxAC/cvarlist.cfg


iluvnitmod.png

Offline

#10 30-Mar-13 04:17:21

obituary
Member
Registered: 10-Mar-13
Posts: 5

Re: I need this download link

N!trox* wrote:

It's private, if we detect a server not allowed to use it will be remotely shutdown.

So you are running code within your mod giving you remote access to my server?

I would not have installed this mod on my server if I knew you had a backdoor installed in the mod.

Anyone could use that as an exploit.

Offline

#11 04-Jul-13 09:16:07

N!trox*
Administrator
Registered: 30-Mar-10
Posts: 1,092

Re: I need this download link

Nobody (including myself, or any of the N!tmod developers) has access to your servers.

It was only for 2.2.1 BETA versions that used to be "private", and "all" it could do was remotely shutdown servers that were not allowed to run private N!tmod 2.2.1 BETA versions.

So far, no servers have been blacklisted or remotely shut down, and I really don't have enough time to check which servers should or should not run these builds hmm

I've removed this feature, because we never used it, and will never need it.


iluvnitmod.png

Offline

#12 04-Jul-13 09:22:31

N!trox*
Administrator
Registered: 30-Mar-10
Posts: 1,092

Re: I need this download link

It seems that this has been discussed on another mod's forums, where they also talk about memory leaks (claiming they have been unresolved for many months, but they probably never read any changelogs...)
Memory leaks have been fixed since September 2012 (rev. 699), which means the above download link ( http://etmods.net/forums/filedl.php?id=3 -- rev 772) is safe.


iluvnitmod.png

Offline

Board footer

Powered by FluxBB