ETMods.net

N!tmod, a Wolfenstein: Enemy Territory Modification!

You are not logged in.

Announcement

You can donate to help us keeping services online.

#1 20-Jun-14 12:08:15

m@sh
Member
Registered: 15-Jun-14
Posts: 11
Website

Banner settings?

Hello smile

What are the cvar commands to be able to set banner?
I use this, but it does not work:

set g_msgs              "180"                       //Delay, in seconds, between banner messages. (see g_msgpos)
set g_msgpos            "128"                       //Banners location (see g_msgs)
set b_banners           "4"                       
set b_banner1           "one"
set b_banner2           "two"
set b_banner3           "three"
set b_banner4           "four"

Thx 4 help!

Greetings

Offline

#2 20-Jun-14 14:46:04

N!trox*
Administrator
Registered: 30-Mar-10
Posts: 1,092

Re: Banner settings?

Seems like you are using values from another mod.

Here are the values you can use in N!tmod (click on the cvars, it will redirect you to the online documentation):
g_msgpos
g_msgs

and the g_msgX is missing from the online documentation, but here's how it works:

g_msgX [string]

    If you want to enable banners on your server, you have to set them. Replace X by a number (g_msg1, g_msg2, g_msg3, etc...)

    Ex.: set g_msg1 "Welcome to N!tmod"
           set g_msg2 "Visit www.etmods.net"

    The first missing g_msgX cvar will start the message cycle over, back to the first message.

    Note: You have to use set g_msgX "text" if you don't use set in front of the cvars, the banners will not work.


iluvnitmod.png

Offline

#3 21-Jun-14 09:01:35

m@sh
Member
Registered: 15-Jun-14
Posts: 11
Website

Re: Banner settings?

Thank you, but it does not work anyway?
What am I doing wrong?

// BANNER
set g_msgpos        "2"                       //Banners location (see g_msgs)
set g_msgs          "180"                     //Delay, in seconds, between banner messages. (see g_msgpos)
set g_msg1          "One"
set g_msg2          "Two"
set g_msg3          "Three"
set g_msg4          "Four"

Offline

#4 21-Jun-14 18:19:48

Grandad
BETA Tester
Registered: 29-Dec-11
Posts: 168

Re: Banner settings?

Your settings are correct, and they Work. I tried on a home server.

But ofcourse, you need to wait 3 minutes before any banner shows up. (set g_msgs   "180"  )

Offline

#5 21-Jun-14 20:00:20

ailmanki
BETA Tester
Registered: 08-Jun-12
Posts: 42
Website

Re: Banner settings?

you can check over rcon if your settings are loaded,
"/rcon cvarlist g_msg"


b_350_20_692108_381007_FFFFFF_000000.pngb_350_20_692108_381007_FFFFFF_000000.png

Offline

#6 22-Jun-14 16:27:44

m@sh
Member
Registered: 15-Jun-14
Posts: 11
Website

Re: Banner settings?

@all
Big THX, it´s running wink

Offline

Board footer

Powered by FluxBB