ETMods.net

N!tmod, a Wolfenstein: Enemy Territory Modification!

You are not logged in.

Announcement

You can donate to help us keeping services online.

#1 23-Feb-15 19:12:12

Exagone313
BETA Tester
Registered: 23-Feb-15
Posts: 43

[OK] Disable "WARMUP: Waiting on 0 players"

Hello,

I create my first ET server with nitmod, and I don't understand why it waits for 0 player. It happens when the teams are empty. How to disable this wait, without disabling warmup?

Here is a part of my config:

set g_gametype "6"
map "purefrag"
set com_watchdog_cmd "map purefrag"
set nextmap "map purefrag"
set match_readypercent "0"
set match_minplayers "0"

Thanks for your help.

EDIT : Finally, i Found: use set g_doWarmup "0"
Please update the cvar page to explain this.

Last edited by Exagone313 (23-Feb-15 19:31:38)

Offline

#2 23-Feb-15 19:22:40

N!trox*
Administrator
Registered: 30-Mar-10
Posts: 1,090

Re: [OK] Disable "WARMUP: Waiting on 0 players"

Hi,

I remember this had already been asked, but I can't find the thread about it.

g_doWarmup: Waits for match_minplayers players before starting warmup countdown.
g_warmup: Warmup countdown duration in seconds.


iluvnitmod.png

Offline

#3 23-Feb-15 19:32:02

Exagone313
BETA Tester
Registered: 23-Feb-15
Posts: 43

Re: [OK] Disable "WARMUP: Waiting on 0 players"

Thanks anyway ^^ I edited for nothing.

Offline

#4 23-Feb-15 20:45:26

N!trox*
Administrator
Registered: 30-Mar-10
Posts: 1,090

Re: [OK] Disable "WARMUP: Waiting on 0 players"

Exagone313 wrote:

EDIT : Finally, i Found: use set g_doWarmup "0"
Please update the cvar page to explain this.

Sorry, I had not seen your edit.
CVAR Reference updated smile


iluvnitmod.png

Offline

#5 24-Feb-15 23:15:26

Grandad
BETA Tester
Registered: 29-Dec-11
Posts: 167

Re: [OK] Disable "WARMUP: Waiting on 0 players"

N!trox* wrote:

Hi,

I remember this had already been asked, but I can't find the thread about it.

g_doWarmup: Waits for match_minplayers players before starting warmup countdown.
g_warmup: Warmup countdown duration in seconds.


Have any of you ever tried:

set g_doWarmup "0"
set g_warmup  "0"

If I do this, I still get a 3 -5 seconds periode of warmup. And I read the text, warmup, on server.
Reading from etconsol.log all bots and players connects 2 times for each map.
LUA is enabled, then disabled, and enabled again, along with bots and players.

In server.cfg I have:
set g_doWarmup "0"
set g_warmup "0"

If I read etconfig.cfg I have:
seta g_doWarmup "0"
seta g_warmup "0"

If I on server do: /rcon password g_warmup
I get: g_warmup is "0" default 60

Anyone ?

Offline

#6 25-Feb-15 00:29:02

N!trox*
Administrator
Registered: 30-Mar-10
Posts: 1,090

Re: [OK] Disable "WARMUP: Waiting on 0 players"

Warmup can't be disabled, it will always be 10 seconds minimum.
You don't see the 10 seconds because of the delay between the moment the servers loads the map and the moment your client finishes loading it.


iluvnitmod.png

Offline

#7 25-Feb-15 01:21:42

Grandad
BETA Tester
Registered: 29-Dec-11
Posts: 167

Re: [OK] Disable "WARMUP: Waiting on 0 players"

N!trox* wrote:

Warmup can't be disabled, it will always be 10 seconds minimum.
You don't see the 10 seconds because of the delay between the moment the servers loads the map and the moment your client finishes loading it.

Warmup can not be disabled, you say. Then I have to ask you, is that MOD related or not ??
And again, how can you say, we will not notice that 10 seconds of warmup. I notice for 3 seconds of warmup, on every map on my server.  ??

I hope for the best wink

Last edited by Grandad (25-Feb-15 02:05:35)

Offline

#8 25-Feb-15 22:11:04

N!trox*
Administrator
Registered: 30-Mar-10
Posts: 1,090

Re: [OK] Disable "WARMUP: Waiting on 0 players"

It has always been this way in ET, it is of course mod relaed in a way that we could change it, but we won't.

And I meant that you will not notice all of the 10 seconds.
The server loads a new map as soon as the intermission time reaches 0. At this moment, clients usually hang for up to 3 seconds, then clients load the map (not every computer loads map at the same speed...), and then you enter the "world" and you can start seeing the warmup countdown.


iluvnitmod.png

Offline

#9 25-Feb-15 23:26:20

Grandad
BETA Tester
Registered: 29-Dec-11
Posts: 167

Re: [OK] Disable "WARMUP: Waiting on 0 players"

Thank you for the answer.

I was going nuts, not find the right way to disable it smile

Offline

Board footer

Powered by FluxBB